<!doctype html>
<!-- paulirish.com/2008/conditional-stylesheets-vs-css-hacks-answer-neither/ -->
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" > <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" > <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" "> <![endif]-->
<!-- Consider adding an manifest.appcache: h5bp.com/d/Offline -->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" > <!--<![endif]-->
<head><meta charset="UTF-8">
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-3&cb=2', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-3&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-3&cb=5', false, [], true, false, true, false);</script>
	

	<title>Samsung Announces Galaxy S21 Unpacked Event for January 14th</title>

	<!-- Mobile viewport optimized: j.mp/bplateviewport -->
	<meta name="viewport" content="width=device-width" />

	<link rel="alternate" type="application/rss+xml" title="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog Feed" href="https://www.androidbeat.com/feed/">

	
	<!--  iPhone Web App Home Screen Icon -->
	<link rel="apple-touch-icon" sizes="72x72" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/devices/apple-touch-icon-ipad.png" />
	<link rel="apple-touch-icon" sizes="114x114" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/devices/apple-touch-icon-ipad3.png" />
	<!--<link rel="apple-touch-icon" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/devices/reverie-icon.png" />-->
	<link rel="shortcut icon" type="image/x-icon" href="https://www.androidbeat.com/wp-content/themes/androidbeat-new/favicon.ico">
	<link rel="stylesheet" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/font-awesome.min.css">
	<link type="text/css" rel="stylesheet" href="https://cdn.jsdelivr.net/jquery.jssocials/1.4.0/jssocials.css" />
	<link type="text/css" rel="stylesheet" href="https://cdn.jsdelivr.net/jquery.jssocials/1.4.0/jssocials-theme-plain.css" />
	<!-- Enable Startup Image for iOS Home Screen Web App -->
	<meta name="apple-mobile-web-app-capable" content="yes" />
	<link rel="apple-touch-startup-image" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/mobile-load.png" />







	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="We have seen numerous leaks and reports on the upcoming Samsung Galaxy S21 series. Samsung has now announced that Galaxy S21, S21 Plus, and S21 Ultra will" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Samsung Announces Galaxy S21 Unpacked Event for January 14th" />
	<meta property="og:description" content="We have seen numerous leaks and reports on the upcoming Samsung Galaxy S21 series. Samsung has now announced that Galaxy S21, S21 Plus, and S21 Ultra will" />
	<meta property="og:url" content="https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/" />
	<meta property="og:site_name" content="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog" />
	<meta property="article:publisher" content="https://www.facebook.com/pages/Android-Beat/151205568375709" />
	<meta property="article:published_time" content="2021-01-04T14:44:41+00:00" />
	<meta property="og:image" content="https://cdn.androidbeat.com/wp-content/uploads/2021/01/galaxy-unpacked-2021-event.png" />
	<meta property="og:image:width" content="1337" />
	<meta property="og:image:height" content="687" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@Android_Beat" />
	<meta name="twitter:site" content="@Android_Beat" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Mahit Huilgol">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.androidbeat.com/#website","url":"https://www.androidbeat.com/","name":"Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog","description":"Take a look at the best Android coverage: All phone, tablets &amp; wearables models news, reviews, specs &amp; apps with Android Beat articles, photos &amp; videos.","potentialAction":[{"@type":"SearchAction","target":"https://www.androidbeat.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/#primaryimage","inLanguage":"en-US","url":"https://cdn.androidbeat.com/wp-content/uploads/2021/01/galaxy-unpacked-2021-event.png","width":1337,"height":687},{"@type":"WebPage","@id":"https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/#webpage","url":"https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/","name":"Samsung Announces Galaxy S21 Unpacked Event for January 14th","isPartOf":{"@id":"https://www.androidbeat.com/#website"},"primaryImageOfPage":{"@id":"https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/#primaryimage"},"datePublished":"2021-01-04T14:44:41+00:00","dateModified":"2021-01-04T14:44:41+00:00","author":{"@id":"https://www.androidbeat.com/#/schema/person/b7ab5f1755cd9f242312b505bc1033cb"},"description":"We have seen numerous leaks and reports on the upcoming Samsung Galaxy S21 series. Samsung has now announced that Galaxy S21, S21 Plus, and S21 Ultra will","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/"]}]},{"@type":"Person","@id":"https://www.androidbeat.com/#/schema/person/b7ab5f1755cd9f242312b505bc1033cb","name":"Mahit Huilgol","image":{"@type":"ImageObject","@id":"https://www.androidbeat.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0ef4fc300ca3885aadb602a93111fcd0?s=96&d=mm&r=g","caption":"Mahit Huilgol"},"sameAs":["http://www.androidbeat.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog &raquo; Samsung Announces Galaxy S21 Unpacked Event for January 14th Comments Feed" href="https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cdn.androidbeat.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='structured-content-frontend-css'  href='https://cdn.androidbeat.com/wp-content/plugins/structured-content/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.androidbeat.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://cdn.androidbeat.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css' type='text/css' media='all' />
<link rel='stylesheet' id='reverie-foundation-stylesheet-css'  href='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/app.css' type='text/css' media='all' />
<link rel='stylesheet' id='reverie-stylesheet-css'  href='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%7CLora%3A400%2C700%7CDroid+Sans+Mono' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='reverie-ie-only-css'  href='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/ie.css' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js' id='jquery-js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/modernizr.js' id='reverie-modernizr-js'></script>
<link rel="https://api.w.org/" href="https://www.androidbeat.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.androidbeat.com/wp-json/wp/v2/posts/33383" /><link rel='shortlink' href='https://www.androidbeat.com/?p=33383' />
<link rel="alternate" type="application/json+oembed" href="https://www.androidbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidbeat.com%2F2021%2F01%2Fsamsung-galaxy-s21-unpacked-event-january-14%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.androidbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidbeat.com%2F2021%2F01%2Fsamsung-galaxy-s21-unpacked-event-january-14%2F&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://www.androidbeat.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/' + 'EFSl9PXRLeci' + '.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script><!-- Stream WordPress user activity plugin v3.6.0 -->
<link rel="alternate" type="application/rss+xml" title="Android Beat" href="https://www.androidbeat.com/feed/atom/" /><link rel="amphtml" href="https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/amp/" />		<style type="text/css" id="wp-custom-css">
			.gallery dl {
    margin-left: 10px;
    margin-right: 0;
}

html{
	overflow-x:hidden;
}		</style>
		
<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>




<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-39236879-2']);
  _gaq.push(['_trackPageview']);
  _gaq.push(['_trackPageLoadTime']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<link rel="stylesheet" type="text/css" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/style.css?ver=1.110">

<script src="https://cdn.androidbeat.com/wp-includes/js/jquery/jquery-migrate.min.js"></script>
<script async src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/app.js"></script>


<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>

<script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//detectdiscovery.com/c4c7b448c3b9a3a6d072c5ac7bcafe41283594aab33b1cd7f0fa8fdc7e88bf8f83e5c30bf684280ea31c3ec0c0402f6287c73b1fc9cefaf1494e54ae8ac7');</script>


<style type="text/css">


	.fluid-width-video-wrapper{
		 position: relative;
    overflow: hidden !important;
    padding-top: 56.25% !important;
		margin-bottom:20px;
	}
	
.fluid-width-video-wrapper iframe, .fluid-width-video-wrapper object, .fluid-width-video-wrapper embed {
    position: absolute;
    top: 0;
    left: 0;
    width: 100% !important;
    height: 100%;
		border:0;
}
	
</style>
	
	<script>
	(function(d, s, host, ipid) {
	  var e = d.createElement(s);
	  e.type = 'application/javascript';
	  e.async = !0;
	  e.src = '//' + host + '/intellitxt/front.asp?ipid=' + ipid;
	  d.getElementsByTagName(s)[0].parentNode.appendChild(e);
	})(document, 'script', 'k.intellitxt.com', 57486);
	</script>
	




<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158818458-3";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-158818458-3', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'androidbeat.com']);
_gaq.push(['f._setDomainName', 'androidbeat.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','androidbeat.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 177639;
var ezdomain = 'androidbeat.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":177639,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"47e4efba-1948-4629-4e5e-dbd0b2e8f06f","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":3,"serverid":"54.226.103.236:14751","state":"VA","t_epoch":1609778760,"template_id":126,"time_on_site_visit":0,"url":"https://www.androidbeat.com/2021/01/samsung-galaxy-s21-unpacked-event-january-14/","user_id":0,"word_count":639,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-3&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_177639=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["47e4efba-1948-4629-4e5e-dbd0b2e8f06f", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>

<body class="post-template-default single single-post postid-33383 single-format-standard antialiased">

<div id="main-wrapper">

<header class="contain-to-grid">
	<div class="row">
		<div class="large-12 columns">
			<div id="main-header">
				<nav class="top-bar" data-topbar>
				    <ul class="title-area">
				        <li class="name">
														<div id="site-logo">
								<span>
									<a href="https://www.androidbeat.com/" title="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog" rel="home"><img src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/logo.png"></a>
								</span>
							</div>	
				        </li>
						<!-- Remove the class "menu-icon" to get rid of menu icon. Take out "Menu" to just have icon alone -->
						<li class="toggle-topbar menu-icon"><a href="#"><span><img src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/menu.png"></span></a></li>
				    </ul>
				    <section class="top-bar-section">
				    <ul class="left"><li class="divider"></li><li id="menu-item-10821" class="menu-item menu-item-main-menu menu-item-phones"><a  href="https://www.androidbeat.com/phones/">Phones</a></li>
<li class="divider"></li><li id="menu-item-10822" class="menu-item menu-item-main-menu menu-item-tablets"><a  href="https://www.androidbeat.com/tablets/">Tablets</a></li>
<li class="divider"></li><li id="menu-item-10823" class="menu-item menu-item-main-menu menu-item-wearables"><a  href="https://www.androidbeat.com/wearables/">Wearables</a></li>
<li class="divider"></li><li id="menu-item-4590" class="menu-item menu-item-main-menu menu-item-reviews"><a  title="Android Phone Reviews" href="https://www.androidbeat.com/reviews/">Reviews</a></li>
<li class="divider"></li><li id="menu-item-9287" class="menu-item menu-item-main-menu menu-item-tips-tricks"><a  href="https://www.androidbeat.com/tips/">Tips &#038; Tricks</a></li>
<li class="divider"></li><li id="menu-item-10824" class="menu-item menu-item-main-menu menu-item-how-tos"><a  href="https://www.androidbeat.com/how-to/">How-Tos</a></li>
<li class="divider"></li><li id="menu-item-9286" class="menu-item menu-item-main-menu menu-item-software"><a  href="https://www.androidbeat.com/software/">Software</a></li>
<li class="divider"></li><li id="menu-item-2757" class="menu-item menu-item-main-menu menu-item-apps"><a  title="Apps" href="https://www.androidbeat.com/apps/">Apps</a></li>
<li class="divider"></li><li id="menu-item-6120" class="menu-item menu-item-main-menu menu-item-root"><a  title="Android Rooting" href="https://www.androidbeat.com/root/">Root</a></li>
</ul>				    </section>
				</nav>
			</div>
		</div>
		<div class="large-12 columns">
			<div id="header-blue">
				<div class="row">
					<div class="large-9 columns">
						<div class="header-widget">
						<div id="text-4"><h3>What&#8217;s Hot:</h3>			<div class="textwidget"><ul>
<li><a title="Samsung Galaxy S10" href="/galaxy-s10/">Galaxy S20</a></li>
<li><a title="OnePlus 8 Pro" href="/oneplus/">OnePlus 8 Pro</a></li>
<li><a title="Android 11" href="/android-11/">Android 11</a></li>
</ul>
</div>
		</div>						</div>
					</div>
					<div class="large-3 columns">
						<div id="menu-search-form">
		                	<script>
							  (function() {
								var cx = '005114245343935402158:wslvrqsj1ki';
								var gcse = document.createElement('script');
								gcse.type = 'text/javascript';
								gcse.async = true;
								gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
								var s = document.getElementsByTagName('script')[0];
								s.parentNode.insertBefore(gcse, s);
							  })();
							</script>
							<gcse:searchbox></gcse:searchbox>
		                </div>
					</div>
					
				</div>
			</div>
		</div>
	</div>
	
	<!-- Starting the Top-Bar -->
	<!-- End of Top-Bar -->
</header>

<!-- Start the main container -->
<div class="container" role="document">
	<div class="row">
		<div class="large-12 columns">

							<div class="ad-block">
					<center>
							<!-- Sortable Desktop Top banner -->
							<div id="ezoic-pub-ad-placeholder-101"> 
								<div class="ad-tag" data-ad-name="Top_Banner_Sortable_970x250" data-ad-size="970x250" ></div>
								<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
								<script>(deployads = window.deployads || []).push({});</script>
							</div>
					</center> 
				</div>
					</div>
<!-- Row for main content area -->
	<div class="small-12 large-8 columns" id="content" role="main">
	<gcse:searchresults defaultToImageSearch="true"></gcse:searchresults>
				<article class="post-33383 post type-post status-publish format-standard has-post-thumbnail hentry category-samsung tag-galaxy-s21-ultra tag-samsung-galaxy-s21 tag-samsung-galaxy-s21-plus" id="post-33383">
			<header>
				<h1 class="entry-title">Samsung Announces Galaxy S21 Unpacked Event for January 14th</h1>
				<small class="postmetadata">Posted by <a href="https://www.androidbeat.com/author/mahit-mh/" title="Posts by Mahit Huilgol" rel="author">Mahit Huilgol</a> on Jan 04, 2021 in <a href="https://www.androidbeat.com/samsung/" rel="category tag">Samsung</a></small>
			</header>

			<!-- <font size="3">Like this post? Share it!</font> -->
			<!-- <div class="addthis_sharing_toolbox" style="padding: 10px 0 0;"></div> -->
										
							<div class="entry-content desktop">							
						
															<!-- Sortable Desktop 300x250 ATF  size:300x250 -->
									<figure><img src="https://cdn.androidbeat.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://cdn.androidbeat.com/wp-content/uploads/2021/01/galaxy-unpacked-2021-event-1024x526.png" class="aligncenter"><noscript><img class="aligncenter" src="https://cdn.androidbeat.com/wp-content/uploads/2021/01/galaxy-unpacked-2021-event-1024x526.png" /></noscript></figure>
<p>We have seen numerous leaks and reports on the upcoming Samsung Galaxy S21 series. Samsung has now announced that Galaxy S21, S21 Plus, and S21 Ultra will be launched on January 14th and has sent invites for the Galaxy Unpacked event. The invitation reads, “Welcome to the Everyday Epic.” It also mentions the time as 7 AM PT/10 AM ET.</p>
<p><span id="more-33383"></span></p>
<p>Samsung is expected to launch a lineup similar to the one launched last year. The lineup starts with Galaxy S21, larger Galaxy S21 Plus, and the premium Galaxy S21 Ultra. Interestingly, the Galaxy S21 Ultra is rumored to arrive with a curved display and <a href="https://www.androidbeat.com/2020/12/fcc-listing-confirms-s-pen-support-on-samsung-galaxy-s21-ultra/">support S-Pen</a> out of the box.</p>
<figure><img src="https://cdn.androidbeat.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://cdn.androidbeat.com/wp-content/uploads/2020/12/galaxy-s21-render-1024x640.jpg" class="aligncenter"><noscript><img class="aligncenter" src="https://cdn.androidbeat.com/wp-content/uploads/2020/12/galaxy-s21-render-1024x640.jpg" /></noscript></figure>
<p>Last month a leaked teaser revealed Galaxy S21 5G rear camera module and certain design aspects. Also of interest is the new Phantom Violet color. That apart, there are already <a href="https://www.androidbeat.com/2020/12/galaxy-s21-5g-official-press-image-leak-punch-hole-display/">tons of renders</a> doing rounds, and this helps us set expectations. The teaser shows off a flat display, a center-aligned punch hole camera, and a somewhat boxy look. Likely, camera options include 12MP primary sensor, 12MP ultrawide sensor, and 64MP telephoto lens.</p>
<p><div class="fluid-width-video-wrapper"><iframe src="https://www.youtube.com/embed/cGTjx0JV_0Y?feature=oembed" frameborder="0" allowfullscreen> frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></p>
<p>The Samsung Galaxy S21 is expected to be available in two storage variants, including 128GB and 256GB. The flagship will be powered by Qualcomm Snapdragon 888 or Exynos, depending on the region under the hood. Samsung is also working on an improvised <a href="https://www.androidbeat.com/2020/12/samsung-galaxy-s21-series-expected-to-arrive-with-bigger-and-better-fingerprint-sensor/">ultrasonic fingerprint sensor</a> that offers better accuracy and performance.</p>
<p>The Samsung Galaxy S21 Ultra is rumored to feature a metal-glass design at the back and Corning Gorilla Victus on the front. It could come with a 6.8-inch Infinity AMOLED display and offer RAM options of up to 12GB on the display front. Lastly, Samsung Galaxy S21 <a href="https://www.androidbeat.com/2020/12/galaxy-s21-europe-pricing-detail/">Europe pricing details</a> are already leaked. Stay tuned for all Galaxy S21 news and leaks.</p>
<p id="share"></p>							

									
								
							
							
							<div class="clear content-clear"></div>	
							
							<!-- <font size="3">Like this post? Share it!</font> -->
							<!-- <div class="addthis_sharing_toolbox" style="padding: 10px 0 0;"></div> -->
								

							<br />
							
							<div class="bc_ads" style="margin-top: 0;">
							

						<!--<p><font size="2"><strong>Related Topics:</strong> </font></p>	-->						
							</div>

							<div class="clear"></div>
					</div>

					<div id="moving">						
						<div style="margin-bottom: 15px;">
							<!-- Sortable Mobile Responsive below the article  size:300x250 -->
															<div id="ezoic-pub-ad-placeholder-105"> 
														<div class="ad-tag" data-ad-name="Sortable Desktop Bottom Banner" data-ad-size="auto" ></div>
							<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
							<script>(deployads = window.deployads || []).push({});</script>
							</div>
						</div>
							
						<div class="entry-utility" style="margin-bottom: 15px;">
												
							<div class="OUTBRAIN" data-widget-id= "TF_6" data-src = "" data-ob-template="pallasmediapteltd" ></div>
						</div><!-- .entry-utility -->				
						
					</div>	
					
					<div class="social-wid social-last">
						<h3>Subscribe to AndroidBeat Daily Newsletter</h3>
						<p style="margin-bottom: 0;">Sign up for our AndroidBeat Daily newsletter to get the top Android news stories and tips delivered to your inbox.</p>
						<!-- Begin Mailchimp Signup Form -->
						
						<style type="text/css">						 
							#mc_embed_signup form{
								display: block;
								position: relative;
								text-align: left;
								padding: 10px 0 10px 0;							
							}	
							#mc_embed_signup .mc-field-group label{   
								display: block;
								margin-bottom: 3px;
								color: #000;
							}
							#mc_embed_signup input[type="email"], #mc_embed_signup input[type="email"]{border:1px solid #ABB0B2}
							#mc_embed_signup .mc-field-group{padding-bottom:5px;}
							#mc_embed_signup #mc-embedded-subscribe-form div.mce_inline_error{
								display: inline-block;
								margin: 2px 0 0 0;
								padding: 5px 0px;								
								-webkit-border-radius: 3px;
								-moz-border-radius: 3px;								
								font-size: 14px;
								font-weight: normal;
								z-index: 1;
								color: #e85c41;								
								background:transparent;
							}
							#mc_embed_signup #mc-embedded-subscribe-form input.mce_inline_error{
								border: 1px solid #e85c41;
							}
							#container #mc_embed_signup input[type="email"], #content #mc_embed_signup input[type="email"]{
								display: block !important;
							}
							#container #mc_embed_signup input[type="submit"], #content #mc_embed_signup input[type="submit"]{
								    font-size: 17px;
									width: 21%;
									height: 40px;
									margin-bottom: 5px;
							}
						</style>
						
						<div id="mc_embed_signup">
							<form action="https://iphonehacks.us2.list-manage.com/subscribe/post?u=f22012a25556ae489853e6b4a&amp;id=d3bf5e3f71" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
								<div id="mc_embed_signup_scroll">								
									
									<div class="mc-field-group">
										<label for="mce-EMAIL">Email Address (required)</label>
										<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
										<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
										<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_f22012a25556ae489853e6b4a_d3bf5e3f71" tabindex="-1" value=""></div>
										<input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button">
									</div>
									<div id="mce-responses" class="clear">
										<div class="response" id="mce-error-response" style="display:none"></div>
										<div class="response" id="mce-success-response" style="display:none"></div>
									</div>								
									<div><p>By signing up, you agree to our <a href="https://www.androidbeat.com/privacy-policy/" target="_blank">Privacy Policy</a>.</p></div>
								</div>
								
							</form>
							<div class="clear"></div>
						</div>
						<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[3]='ADDRESS';ftypes[3]='address';fnames[4]='PHONE';ftypes[4]='phone';fnames[5]='MMERGE5';ftypes[5]='text';fnames[6]='MMERGE6';ftypes[6]='text';fnames[7]='MMERGE7';ftypes[7]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
						<!--End mc_embed_signup-->				
					</div>
					<div class="clear"></div>

				
			
		</article>		
		
<div id="disqus_thread"></div>
	
	</div>
	<aside id="sidebar" class="small-12 large-4 columns">
<ul>
			<li id="execphp-3" class="widget-container widget_execphp">			<div class="execphpwidget">	
	<div class="widget-content" style="margin-bottom: 20px;
">
        <div id="ezoic-pub-ad-placeholder-102"> 
            <!-- Sortable Desktop 300x250 ATF  size:300x250 -->
            <div class="ad-tag" data-ad-name="Sortable Desktop 300x250 ATF" data-ad-size="300x250" ></div>
            <script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
            <script>(deployads = window.deployads || []).push({});</script>
            <div class="clear"></div>
        </div>
	</div>	
		</div>
		</li><style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-4" class="widget-container rpwe_widget recent-posts-extended"><h3 class="widget-title tk-museo-sans">Featured Stories</h3><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/10/review-google-pixel-5-the-diminutive-flagship-to-take-you-through-2024/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/10/texture-75x50.jpg" alt="Review: Google Pixel 5 &#8211; the diminutive flagship to take you through 2024"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/10/review-google-pixel-5-the-diminutive-flagship-to-take-you-through-2024/" title="Permalink to Review: Google Pixel 5 &#8211; the diminutive flagship to take you through 2024" rel="bookmark">Review: Google Pixel 5 &#8211; the diminutive flagship to take you through 2024</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/05/oneplus-8-pro-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/05/oneplus8pro-cams-75x50.jpg" alt="The OnePlus 8 Pro Review: The Best Android Phone in the World Right Now"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/05/oneplus-8-pro-review/" title="Permalink to The OnePlus 8 Pro Review: The Best Android Phone in the World Right Now" rel="bookmark">The OnePlus 8 Pro Review: The Best Android Phone in the World Right Now</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/03/use-android-phone-bring-life-sized-3d-animals-living-room/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/03/android-3d-animal-75x50.png" alt="How to Use Android Phone to Bring Life-Sized 3D Animals in Your Living Room"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/03/use-android-phone-bring-life-sized-3d-animals-living-room/" title="Permalink to How to Use Android Phone to Bring Life-Sized 3D Animals in Your Living Room" rel="bookmark">How to Use Android Phone to Bring Life-Sized 3D Animals in Your Living Room</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/03/samsung-galaxy-s20-plus-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/03/s20-front-75x50.jpg" alt="Samsung Galaxy S20 / S20+ Review &#8211; A Mixed Bag, Not a &#8216;Must&#8217; Upgrade"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/03/samsung-galaxy-s20-plus-review/" title="Permalink to Samsung Galaxy S20 / S20+ Review &#8211; A Mixed Bag, Not a &#8216;Must&#8217; Upgrade" rel="bookmark">Samsung Galaxy S20 / S20+ Review &#8211; A Mixed Bag, Not a &#8216;Must&#8217; Upgrade</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/02/top-android-11-features/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/02/Top-Android-11-Features-75x50.jpg" alt="Top 15+ Android 11 Features You Should Know"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/02/top-android-11-features/" title="Permalink to Top 15+ Android 11 Features You Should Know" rel="bookmark">Top 15+ Android 11 Features You Should Know</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border: 0;
margin: 0;
padding: 10px 5px 10px 5px;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}

#sidebar  .rpwe-block li:first-child {
padding-top: 0;
}


#sidebar .rpwe-block li:nth-child(even){
background: #f2f2f2;
}

#sidebar .rpwe-thumb {
border: 0 !important;
box-shadow: none !important;
margin: 0 20px 0 0;
padding: 4px 0 0 !important;
}</style><li id="rpwe_widget-2" class="widget-container rpwe_widget recent-posts-extended"><h3 class="widget-title tk-museo-sans">Latest Posts</h3><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2021/01/poco-f2-teased-specifications/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2021/01/poco-f2-teaser-75x50.png" alt="Poco F2 Teased in New Video, Likely to Be Powered by Snapdragon 732G"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2021/01/poco-f2-teased-specifications/" title="Permalink to Poco F2 Teased in New Video, Likely to Be Powered by Snapdragon 732G" rel="bookmark">Poco F2 Teased in New Video, Likely to Be Powered by Snapdragon 732G</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/12/geekbench-listing-reveals-motorola-capri-specifications/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/12/motorola-capri-render-75x50.jpg" alt="Geekbench Listing Reveals Motorola Capri Specifications"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/12/geekbench-listing-reveals-motorola-capri-specifications/" title="Permalink to Geekbench Listing Reveals Motorola Capri Specifications" rel="bookmark">Geekbench Listing Reveals Motorola Capri Specifications</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/12/galaxy-s21-series-no-charger-headset/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/12/galaxy-s21-render-75x50.jpg" alt="Tipster Says Samsung Galaxy S21 Series Will Ditch In-Box Wall Charger and Headsets"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/12/galaxy-s21-series-no-charger-headset/" title="Permalink to Tipster Says Samsung Galaxy S21 Series Will Ditch In-Box Wall Charger and Headsets" rel="bookmark">Tipster Says Samsung Galaxy S21 Series Will Ditch In-Box Wall Charger and Headsets</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/12/vivo-y20-price-features-specification/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/12/vivo-y20-2021-75x50.jpg" alt="Vivo Y20(2021) Launched with Helio P35, 5,000mAh Battery"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/12/vivo-y20-price-features-specification/" title="Permalink to Vivo Y20(2021) Launched with Helio P35, 5,000mAh Battery" rel="bookmark">Vivo Y20(2021) Launched with Helio P35, 5,000mAh Battery</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/12/oneplus-9-periscope-lens-missing/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/12/oneplus-9-5g-leak-75x50.jpg" alt="New Report Says OnePlus 9 Will Not Come with Periscope Lens"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/12/oneplus-9-periscope-lens-missing/" title="Permalink to New Report Says OnePlus 9 Will Not Come with Periscope Lens" rel="bookmark">New Report Says OnePlus 9 Will Not Come with Periscope Lens</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li><li id="execphp-6" class="widget-container widget_execphp">			<div class="execphpwidget">	<!-- Sortable Desktop 300x600 ATF  size:300x600 -->
    <div id="ezoic-pub-ad-placeholder-104"> 
	<div class="ad-tag" data-ad-name="Sortable Desktop Skyscraper" data-ad-size="auto" ></div>
    </div>
	<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
	<script>(deployads = window.deployads || []).push({});</script>
	</div>
		</li><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border: 0;
margin: 0;
padding: 10px 5px 10px 5px;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}

#sidebar  .rpwe-block li:first-child {
padding-top: 0;
}


#sidebar .rpwe-block li:nth-child(even){
background: #f2f2f2;
}

#sidebar .rpwe-thumb {
border: 0 !important;
box-shadow: none !important;
margin: 0 20px 0 0;
padding: 4px 0 0 !important;
}</style><li id="rpwe_widget-3" class="widget-container rpwe_widget recent-posts-extended"><h3 class="widget-title tk-museo-sans">Reviews</h3><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/10/review-google-pixel-5-the-diminutive-flagship-to-take-you-through-2024/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/10/texture-75x50.jpg" alt="Review: Google Pixel 5 &#8211; the diminutive flagship to take you through 2024"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/10/review-google-pixel-5-the-diminutive-flagship-to-take-you-through-2024/" title="Permalink to Review: Google Pixel 5 &#8211; the diminutive flagship to take you through 2024" rel="bookmark">Review: Google Pixel 5 &#8211; the diminutive flagship to take you through 2024</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/05/oneplus-8-pro-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/05/oneplus8pro-cams-75x50.jpg" alt="The OnePlus 8 Pro Review: The Best Android Phone in the World Right Now"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/05/oneplus-8-pro-review/" title="Permalink to The OnePlus 8 Pro Review: The Best Android Phone in the World Right Now" rel="bookmark">The OnePlus 8 Pro Review: The Best Android Phone in the World Right Now</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/03/samsung-galaxy-s20-plus-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/03/s20-front-75x50.jpg" alt="Samsung Galaxy S20 / S20+ Review &#8211; A Mixed Bag, Not a &#8216;Must&#8217; Upgrade"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/03/samsung-galaxy-s20-plus-review/" title="Permalink to Samsung Galaxy S20 / S20+ Review &#8211; A Mixed Bag, Not a &#8216;Must&#8217; Upgrade" rel="bookmark">Samsung Galaxy S20 / S20+ Review &#8211; A Mixed Bag, Not a &#8216;Must&#8217; Upgrade</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/12/google-pixel-4-xl-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/11/IMG_0418-75x50.jpg" alt="Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/12/google-pixel-4-xl-review/" title="Permalink to Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship" rel="bookmark">Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/08/redmi-k20-pro-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/08/redmi-k20-rear-75x50.jpg" alt="Redmi K20 Pro Review: Value Flagship"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/08/redmi-k20-pro-review/" title="Permalink to Redmi K20 Pro Review: Value Flagship" rel="bookmark">Redmi K20 Pro Review: Value Flagship</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/05/pixel-3a-xl-differences-hands-on-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/05/3axl-front-75x50.jpg" alt="Google Pixel 3a to 3a XL: Differences, Hands-on Review"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/05/pixel-3a-xl-differences-hands-on-review/" title="Permalink to Google Pixel 3a to 3a XL: Differences, Hands-on Review" rel="bookmark">Google Pixel 3a to 3a XL: Differences, Hands-on Review</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li><li id="text-9" class="widget-container widget_text"><h3 class="widget-title tk-museo-sans">Follow Android Beat</h3>			<div class="textwidget"><div class="social-sidebar">
 <ul>
	        <li><a href="//www.facebook.com/pages/Android-Beat/151205568375709" class="entypo-facebook" target="_blank" rel="noopener noreferrer"><i class="fa fa-facebook" aria-hidden="true"></i></a></li>
	        <li><a href="//twitter.com/Android_Beat" class="entypo-twitter" target="_blank" rel="noopener noreferrer"><i class="fa fa-twitter" aria-hidden="true"></i></a></li>
<li><a href="//www.androidbeat.com/feed" class="entypo-rss" target="_blank" rel="noopener noreferrer"><i class="fa fa-rss" aria-hidden="true"></i></a></li>
	    </ul>
</div></div>
		</li>		</ul>
</aside><!-- /#sidebar -->



		
	</div><!-- Row End -->
</div><!-- Container End -->
<div class="row">
	<div class="large-12 columns" id="breadcrumbs">
		<a href="https://www.androidbeat.com">Home</a>
	</div>
	<div class="large-12 columns" id="the-footer">
		<div class="row">
			

			<div id="footer-widget-area" role="complementary">

				<div id="first" class="widget-area large-3 columns">
					<ul class="xoxo">
						<li id="text-3" class="widget-container widget_text"><h3 class="widget-title">Disclaimer</h3>			<div class="textwidget"><div>Android is a trademark of Google Inc. <a class="vglink" href="https://www.androidbeat.com">AndroidBeat.com</a> is not affiliated with Google or any of the device manufacturers listed on this site. All images, logos and trademarks used on this site are property of their respective owners. We are an Android Enthusiast site.</div>
</div>
		</li>					</ul>
				</div><!-- #first .widget-area -->

				<div id="second" class="widget-area large-3 columns">
					<ul class="xoxo">
						<li id="pages-2" class="widget-container widget_pages"><h3 class="widget-title">Pages</h3>
			<ul>
				<li class="page_item page-item-65"><a href="https://www.androidbeat.com/about/">About Us</a></li>
<li class="page_item page-item-27"><a href="https://www.androidbeat.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-26"><a href="https://www.androidbeat.com/privacy-policy/">Privacy Policy</a></li>
			</ul>

			</li>					</ul>
				</div><!-- #second .widget-area -->



			</div><!-- #footer-widget-area -->
		</div>
		<div class="row">
			<div class="large-12 columns">
				<p class="design-by">
					Designed by <a href="//www.blogconsulting.com/" rel="nofollow">Blog Consulting</a>
				</p>
			</div>
		</div>
		<div class="fordesign"></div>
	</div>
</div>
</div>

<script type='text/javascript' src='https://cdn.androidbeat.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidbeat"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"33383 https:\/\/www.androidbeat.com\/?p=33383","disqusShortname":"androidbeat","disqusTitle":"Samsung Announces Galaxy S21 Unpacked Event for January 14th","disqusUrl":"https:\/\/www.androidbeat.com\/2021\/01\/samsung-galaxy-s21-unpacked-event-january-14\/","postId":"33383"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js' id='jquery-sonar-js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/lazy-load/js/lazy-load.js' id='wpcom-lazy-load-images-js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js' id='q2w3_fixed_widget-js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/foundation.min.js' id='reverie-js-js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>



<!-- <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-53f192b25dff6022" async="async"></script> -->

<script type="text/javascript" src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/jquery.fitvids.js"></script>
<script type="text/javascript">
var clicky_site_ids = clicky_site_ids || [];
clicky_site_ids.push(100673631);
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//static.getclicky.com/js';
  ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
})();

$(document).ready(function(){
	 
});	
</script>

<script>
	(function($) {
		$(document).foundation();
		
	})(jQuery);
</script>


<script type="text/javascript" src="https://cdn.jsdelivr.net/jquery.jssocials/1.4.0/jssocials.min.js"></script>
<script type="text/javascript">
	jQuery("#share").jsSocials({
		shareIn: "popup",
		showLabel: false,
		showCount: false,
		shares: ["facebook","twitter",{ share: "email", logo: "fa fa-envelope" }]
	});
</script>
<script type="text/javascript">
$(document).ready(function(){
	
	$(".entry-content").fitVids();
});
</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=3&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=3&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="androidbeat_com",_audins_did=177639;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-3");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.androidbeat_com,DomainId.177639" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>