<!doctype html>
<!-- paulirish.com/2008/conditional-stylesheets-vs-css-hacks-answer-neither/ -->
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US" > <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US" > <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US" "> <![endif]-->
<!-- Consider adding an manifest.appcache: h5bp.com/d/Offline -->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" > <!--<![endif]-->
<head>
	<meta charset="UTF-8">

	<title>Reference to Google Pixel 5 Found in AOSP Code</title>

	<!-- Mobile viewport optimized: j.mp/bplateviewport -->
	<meta name="viewport" content="width=device-width" />

	<link rel="alternate" type="application/rss+xml" title="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog Feed" href="https://www.androidbeat.com/feed/">

	
	<!--  iPhone Web App Home Screen Icon -->
	<link rel="apple-touch-icon" sizes="72x72" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/devices/apple-touch-icon-ipad.png" />
	<link rel="apple-touch-icon" sizes="114x114" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/devices/apple-touch-icon-ipad3.png" />
	<!--<link rel="apple-touch-icon" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/devices/reverie-icon.png" />-->
	<link rel="shortcut icon" type="image/x-icon" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/favicon.ico">
	<link rel="stylesheet" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/font-awesome.min.css">
	<link type="text/css" rel="stylesheet" href="https://cdn.jsdelivr.net/jquery.jssocials/1.4.0/jssocials.css" />
	<link type="text/css" rel="stylesheet" href="https://cdn.jsdelivr.net/jquery.jssocials/1.4.0/jssocials-theme-plain.css" />
	<!-- Enable Startup Image for iOS Home Screen Web App -->
	<meta name="apple-mobile-web-app-capable" content="yes" />
	<link rel="apple-touch-startup-image" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/mobile-load.png" />







<!-- This site is optimized with the Yoast SEO plugin v12.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="As with every year, Google will pull the wraps from its Pixel series later this year. The company is expected to launch Pixel 4a and Pixel 5. Thanks to"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Reference to Google Pixel 5 Found in AOSP Code" />
<meta property="og:description" content="As with every year, Google will pull the wraps from its Pixel series later this year. The company is expected to launch Pixel 4a and Pixel 5. Thanks to" />
<meta property="og:url" content="https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/" />
<meta property="og:site_name" content="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog" />
<meta property="article:publisher" content="https://www.facebook.com/pages/Android-Beat/151205568375709" />
<meta property="article:tag" content="Google Pixel" />
<meta property="article:tag" content="Pixel 4a" />
<meta property="article:tag" content="Pixel 5" />
<meta property="article:tag" content="Pixel 5XL" />
<meta property="article:section" content="Google Pixel" />
<meta property="article:published_time" content="2020-02-18T20:26:11+00:00" />
<meta property="og:image" content="https://cdn.androidbeat.com/wp-content/uploads/2019/11/IMG_0415.jpg" />
<meta property="og:image:secure_url" content="https://cdn.androidbeat.com/wp-content/uploads/2019/11/IMG_0415.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="620" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="As with every year, Google will pull the wraps from its Pixel series later this year. The company is expected to launch Pixel 4a and Pixel 5. Thanks to" />
<meta name="twitter:title" content="Reference to Google Pixel 5 Found in AOSP Code" />
<meta name="twitter:site" content="@Android_Beat" />
<meta name="twitter:image" content="https://cdn.androidbeat.com/wp-content/uploads/2019/11/IMG_0415.jpg" />
<meta name="twitter:creator" content="@Android_Beat" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.androidbeat.com/#website","url":"https://www.androidbeat.com/","name":"Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog","description":"Take a look at the best Android coverage: All phone, tablets &amp; wearables models news, reviews, specs &amp; apps with Android Beat articles, photos &amp; videos.","potentialAction":{"@type":"SearchAction","target":"https://www.androidbeat.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/#primaryimage","url":"https://cdn.androidbeat.com/wp-content/uploads/2019/11/IMG_0415.jpg","width":800,"height":620,"caption":"Pixel 4 XL back"},{"@type":"WebPage","@id":"https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/#webpage","url":"https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/","inLanguage":"en-US","name":"Reference to Google Pixel 5 Found in AOSP Code","isPartOf":{"@id":"https://www.androidbeat.com/#website"},"primaryImageOfPage":{"@id":"https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/#primaryimage"},"datePublished":"2020-02-18T20:26:11+00:00","dateModified":"2020-02-18T20:26:11+00:00","author":{"@id":"https://www.androidbeat.com/#/schema/person/b576471acf93e03f219b6a7201e30ee2"},"description":"As with every year, Google will pull the wraps from its Pixel series later this year. The company is expected to launch Pixel 4a and Pixel 5. Thanks to"},{"@type":["Person"],"@id":"https://www.androidbeat.com/#/schema/person/b576471acf93e03f219b6a7201e30ee2","name":"Mahit Huilgol","image":{"@type":"ImageObject","@id":"https://www.androidbeat.com/#authorlogo","url":"https://secure.gravatar.com/avatar/0ef4fc300ca3885aadb602a93111fcd0?s=96&d=mm&r=g","caption":"Mahit Huilgol"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog &raquo; Reference to Google Pixel 5 Found in AOSP Code Comments Feed" href="https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.androidbeat.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='structured-content-frontend-css'  href='https://cdn.androidbeat.com/wp-content/plugins/structured-content/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://cdn.androidbeat.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://cdn.androidbeat.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css' type='text/css' media='all' />
<link rel='stylesheet' id='reverie-foundation-stylesheet-css'  href='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/app.css' type='text/css' media='all' />
<link rel='stylesheet' id='reverie-stylesheet-css'  href='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-font-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%7CLora%3A400%2C700%7CDroid+Sans+Mono' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='reverie-ie-only-css'  href='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/css/ie.css' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/modernizr.js'></script>
<link rel='https://api.w.org/' href='https://www.androidbeat.com/wp-json/' />
<link rel='shortlink' href='https://www.androidbeat.com/?p=31330' />
<link rel="alternate" type="application/json+oembed" href="https://www.androidbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidbeat.com%2F2020%2F02%2Fpixel-5-reference-aosp-code%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.androidbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidbeat.com%2F2020%2F02%2Fpixel-5-reference-aosp-code%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.4.2 -->
<link rel="alternate" type="application/rss+xml" title="Android Beat" href="https://www.androidbeat.com/feed/atom/" /><link rel="amphtml" href="https://www.androidbeat.com/2020/02/pixel-5-reference-aosp-code/amp/" />
<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>




<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-39236879-2']);
  _gaq.push(['_trackPageview']);
  _gaq.push(['_trackPageLoadTime']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<link rel="stylesheet" type="text/css" href="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/style.css?ver=1.108">

<script src="https://cdn.androidbeat.com/wp-includes/js/jquery/jquery-migrate.min.js"></script>
<script async src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/app.js"></script>


<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>

<script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//detectdiscovery.com/c4c7b448c3b9a3a6d072c5ac7bcafe41283594aab33b1cd7f0fa8fdc7e88bf8f83e5c30bf684280ea31c3ec0c0402f6287c73b1fc9cefaf1494e54ae8ac7');</script>



</head>

<body class="post-template-default single single-post postid-31330 single-format-standard antialiased">

<div id="main-wrapper">

<header class="contain-to-grid">
	<div class="row">
		<div class="large-12 columns">
			<div id="main-header">
				<nav class="top-bar" data-topbar>
				    <ul class="title-area">
				        <li class="name">
														<div id="site-logo">
								<span>
									<a href="https://www.androidbeat.com/" title="Android Beat | Android News, Hacks, Apps, Tips &amp; Reviews Blog" rel="home"><img src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/logo.png"></a>
								</span>
							</div>	
				        </li>
						<!-- Remove the class "menu-icon" to get rid of menu icon. Take out "Menu" to just have icon alone -->
						<li class="toggle-topbar menu-icon"><a href="#"><span><img src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/img/menu.png"></span></a></li>
				    </ul>
				    <section class="top-bar-section">
				    <ul class="left"><li class="divider"></li><li id="menu-item-10821" class="menu-item menu-item-main-menu menu-item-phones"><a  href="https://www.androidbeat.com/phones/">Phones</a></li>
<li class="divider"></li><li id="menu-item-10822" class="menu-item menu-item-main-menu menu-item-tablets"><a  href="https://www.androidbeat.com/tablets/">Tablets</a></li>
<li class="divider"></li><li id="menu-item-10823" class="menu-item menu-item-main-menu menu-item-wearables"><a  href="https://www.androidbeat.com/wearables/">Wearables</a></li>
<li class="divider"></li><li id="menu-item-4590" class="menu-item menu-item-main-menu menu-item-reviews"><a  title="Android Phone Reviews" href="https://www.androidbeat.com/reviews/">Reviews</a></li>
<li class="divider"></li><li id="menu-item-9287" class="menu-item menu-item-main-menu menu-item-tips-tricks"><a  href="https://www.androidbeat.com/tips/">Tips &#038; Tricks</a></li>
<li class="divider"></li><li id="menu-item-10824" class="menu-item menu-item-main-menu menu-item-how-tos"><a  href="https://www.androidbeat.com/how-to/">How-Tos</a></li>
<li class="divider"></li><li id="menu-item-9286" class="menu-item menu-item-main-menu menu-item-software"><a  href="https://www.androidbeat.com/software/">Software</a></li>
<li class="divider"></li><li id="menu-item-2757" class="menu-item menu-item-main-menu menu-item-apps"><a  title="Apps" href="https://www.androidbeat.com/apps/">Apps</a></li>
<li class="divider"></li><li id="menu-item-6120" class="menu-item menu-item-main-menu menu-item-root"><a  title="Android Rooting" href="https://www.androidbeat.com/root/">Root</a></li>
</ul>				    </section>
				</nav>
			</div>
		</div>
		<div class="large-12 columns">
			<div id="header-blue">
				<div class="row">
					<div class="large-9 columns">
						<div class="header-widget">
						<div id="text-4"><h3>What&#8217;s Hot:</h3>			<div class="textwidget"><ul>
<li><a title="Samsung Galaxy S10" href="/galaxy-s10/">Galaxy S10</a></li>
<li><a title="Huawei P30 Pro" href="/huawei-p30/">Huawei P30 Pro</a></li>
<li><a title="Redmi Note 7" href="/redmi-note-7/">Redmi Note 7</a></li>
<li><a title="OnePlus 7" href="/oneplus-7/">OnePlus 7</a></li>
</ul>
</div>
		</div>						</div>
					</div>
					<div class="large-3 columns">
						<div id="menu-search-form">
		                	<script>
							  (function() {
								var cx = '005114245343935402158:wslvrqsj1ki';
								var gcse = document.createElement('script');
								gcse.type = 'text/javascript';
								gcse.async = true;
								gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
								var s = document.getElementsByTagName('script')[0];
								s.parentNode.insertBefore(gcse, s);
							  })();
							</script>
							<gcse:searchbox></gcse:searchbox>
		                </div>
					</div>
					
				</div>
			</div>
		</div>
	</div>
	
	<!-- Starting the Top-Bar -->
	<!-- End of Top-Bar -->
</header>

<!-- Start the main container -->
<div class="container" role="document">
	<div class="row">
		<div class="large-12 columns">

							<div class="ad-block">
					<center>
							<!-- Sortable Desktop Top banner -->
							<div class="ad-tag" data-ad-name="Top_Banner_Sortable_970x250" data-ad-size="970x250" ></div>
							<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
							<script>(deployads = window.deployads || []).push({});</script>
					</center> 
				</div>
					</div>
<!-- Row for main content area -->
	<div class="small-12 large-8 columns" id="content" role="main">
	<gcse:searchresults defaultToImageSearch="true"></gcse:searchresults>
				<article class="post-31330 post type-post status-publish format-standard has-post-thumbnail hentry category-google-pixel tag-google-pixel tag-pixel-4a tag-pixel-5 tag-pixel-5xl" id="post-31330">
			<header>
				<h1 class="entry-title">Reference to Google Pixel 5 Found in AOSP Code</h1>
				<small class="postmetadata">Posted by <a href="https://www.androidbeat.com/author/mahit-mh/" title="Posts by Mahit Huilgol" rel="author">Mahit Huilgol</a> on Feb 18, 2020 in <a href="https://www.androidbeat.com/google-pixel/" rel="category tag">Google Pixel</a></small>
			</header>

			<!-- <font size="3">Like this post? Share it!</font> -->
			<!-- <div class="addthis_sharing_toolbox" style="padding: 10px 0 0;"></div> -->
										
							<div class="entry-content desktop">							
						
															<!-- Sortable Desktop 300x250 ATF  size:300x250 -->
									<figure><img src="https://cdn.androidbeat.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://cdn.androidbeat.com/wp-content/uploads/2019/10/pixel-4-orange-1024x1024.jpg" class="aligncenter"><noscript><img class="aligncenter" src="https://cdn.androidbeat.com/wp-content/uploads/2019/10/pixel-4-orange-1024x1024.jpg" /></noscript></figure>
<p>As with every year, Google will pull the wraps from its Pixel series later this year. The company is expected to launch Pixel 4a and Pixel 5. Thanks to rumor mills we know a fair share about Pixel 4a, however, nothing leaked about Pixel 5. Now a reference to Pixel 5 has been unearthed on AOSP code.</p>
<p><span id="more-31330"></span></p>
<p>The details about code are immaterial, what is interesting is the version numbers associated with the code. For instance, the note mentions “Pixel 4 at 4.14” and “Pixel 5 with 4.19.” The Linux numbers used by Android is generated and shared by Qualcomm.</p>
<figure><img src="https://cdn.androidbeat.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://cdn.androidbeat.com/wp-content/uploads/2020/02/pixel-5-refernce.png" class="aligncenter"><noscript><img class="aligncenter" src="https://cdn.androidbeat.com/wp-content/uploads/2020/02/pixel-5-refernce.png" /></noscript></figure>
<p>&nbsp;</p>
<p>Previously, we have learned about three codenames associated with <a href="http://androidbeat.com/google-pixel">Google Pixel</a>. The Sunfish most likely hints at Pixel 4a while the Redfin and Bramble refer to Google Pixel 5 and Pixel 5 XL. The device codenamed Bramble has been seen using 4.19 kernel version for Pixel 5. In all likelihood, the Bramble is the Pixel 5. All said and done, we can be pretty sure that Google is working on Pixel 5 and the device might be unveiled sooner than expected.</p>
<p>One of the reports claimed that Google will offer only one Pixel device this year and this will be the Pixel 4a. However, the latest references on the AOSP code contradict the report and hint at Pixel 5. Thanks to renders, we have seen how Pixel 4A looks like. As far as specifications are concerned, the Pixel 4a is expected to be powered by Qualcomm Snapdragon 765, 5.7-inch display, 4GB of RAM and a single(!) 12.2MP camera. Off-course these are all just rumors and presumably, the Pixel will come with slightly different specs.</p>
<p>[via <a href="https://9to5google.com/2020/02/17/google-pixel-5-android-open-source-project/">9to5 Google</a>]</p>
<p id="share"></p>							

									
								
							
							
							<div class="clear content-clear"></div>	
							
							<!-- <font size="3">Like this post? Share it!</font> -->
							<!-- <div class="addthis_sharing_toolbox" style="padding: 10px 0 0;"></div> -->
								

							<br />
							
							<div class="bc_ads" style="margin-top: 0;">
							

						<!--<p><font size="2"><strong>Related Topics:</strong> </font></p>	-->						
							</div>

							<div class="clear"></div>
					</div>

					<div id="moving">						
						<div style="margin-bottom: 15px;">
							<!-- Sortable Mobile Responsive below the article  size:300x250 -->
							<div class="ad-tag" data-ad-name="Sortable Desktop Bottom Banner" data-ad-size="auto" ></div>
							<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
							<script>(deployads = window.deployads || []).push({});</script>
						</div>
							
						<div class="entry-utility" style="margin-bottom: 15px;">
												
							<div class="OUTBRAIN" data-widget-id= "TF_6" data-src = "" data-ob-template="pallasmediapteltd" ></div>
						</div><!-- .entry-utility -->				
						
					</div>	
					
					<div class="social-wid social-last">
						<h3>Subscribe to AndroidBeat Daily Newsletter</h3>
						<p style="margin-bottom: 0;">Sign up for our AndroidBeat Daily newsletter to get the top Android news stories and tips delivered to your inbox.</p>
						<!-- Begin Mailchimp Signup Form -->
						
						<style type="text/css">						 
							#mc_embed_signup form{
								display: block;
								position: relative;
								text-align: left;
								padding: 10px 0 10px 0;							
							}	
							#mc_embed_signup .mc-field-group label{   
								display: block;
								margin-bottom: 3px;
								color: #000;
							}
							#mc_embed_signup input[type="email"], #mc_embed_signup input[type="email"]{border:1px solid #ABB0B2}
							#mc_embed_signup .mc-field-group{padding-bottom:5px;}
							#mc_embed_signup #mc-embedded-subscribe-form div.mce_inline_error{
								display: inline-block;
								margin: 2px 0 0 0;
								padding: 5px 0px;								
								-webkit-border-radius: 3px;
								-moz-border-radius: 3px;								
								font-size: 14px;
								font-weight: normal;
								z-index: 1;
								color: #e85c41;								
								background:transparent;
							}
							#mc_embed_signup #mc-embedded-subscribe-form input.mce_inline_error{
								border: 1px solid #e85c41;
							}
							#container #mc_embed_signup input[type="email"], #content #mc_embed_signup input[type="email"]{
								display: block !important;
							}
							#container #mc_embed_signup input[type="submit"], #content #mc_embed_signup input[type="submit"]{
								    font-size: 17px;
									width: 21%;
									height: 40px;
									margin-bottom: 5px;
							}
						</style>
						
						<div id="mc_embed_signup">
							<form action="https://iphonehacks.us2.list-manage.com/subscribe/post?u=f22012a25556ae489853e6b4a&amp;id=d3bf5e3f71" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
								<div id="mc_embed_signup_scroll">								
									
									<div class="mc-field-group">
										<label for="mce-EMAIL">Email Address (required)</label>
										<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
										<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
										<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_f22012a25556ae489853e6b4a_d3bf5e3f71" tabindex="-1" value=""></div>
										<input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button">
									</div>
									<div id="mce-responses" class="clear">
										<div class="response" id="mce-error-response" style="display:none"></div>
										<div class="response" id="mce-success-response" style="display:none"></div>
									</div>								
									<div><p>By signing up, you agree to our <a href="https://www.androidbeat.com/privacy-policy/" target="_blank">Privacy Policy</a>.</p></div>
								</div>
								
							</form>
							<div class="clear"></div>
						</div>
						<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[3]='ADDRESS';ftypes[3]='address';fnames[4]='PHONE';ftypes[4]='phone';fnames[5]='MMERGE5';ftypes[5]='text';fnames[6]='MMERGE6';ftypes[6]='text';fnames[7]='MMERGE7';ftypes[7]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
						<!--End mc_embed_signup-->				
					</div>
					<div class="clear"></div>

				
			
		</article>		
		
<div id="disqus_thread"></div>
	
	</div>
	<aside id="sidebar" class="small-12 large-4 columns">
<ul>
			<li id="execphp-3" class="widget-container widget_execphp">			<div class="execphpwidget">	
	<div class="widget-content" style="margin-bottom: 20px;
">
		<!-- Sortable Desktop 300x250 ATF  size:300x250 -->
		<div class="ad-tag" data-ad-name="Sortable Desktop 300x250 ATF" data-ad-size="300x250" ></div>
		<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
		<script>(deployads = window.deployads || []).push({});</script>
		<div class="clear"></div>
	</div>	
		</div>
		</li><style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-4" class="widget-container rpwe_widget recent-posts-extended"><h3 class="widget-title tk-museo-sans">Featured Stories</h3><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/12/google-pixel-4-xl-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/11/IMG_0418-75x50.jpg" alt="Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/12/google-pixel-4-xl-review/" title="Permalink to Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship" rel="bookmark">Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship</a></h3></li><li class="rpwe-li rpwe-clearfix"><a href="https://www.androidbeat.com/2019/08/samsung-galaxy-note-10-ip68-certification/"><img  class="thumbnail post-thumbnail rpwe-alignleft rpwe-thumb get-the-image" width="75" height="50" alt="What the Samsung Galaxy Note 10&#039;s IP68 Certification Mean" itemprop="image" src="https://cdn.androidbeat.com/wp-content/uploads/2019/08/Samsung-Galaxy-Note10-Plus-white-front.png" /></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/08/samsung-galaxy-note-10-ip68-certification/" title="Permalink to What the Samsung Galaxy Note 10&#8217;s IP68 Certification Mean" rel="bookmark">What the Samsung Galaxy Note 10&#8217;s IP68 Certification Mean</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/05/how-make-money-android/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/05/How-to-Make-Money-on-Your-Android-Phone-75x50.png" alt="How to Make Money on Your Android Phone"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/05/how-make-money-android/" title="Permalink to How to Make Money on Your Android Phone" rel="bookmark">How to Make Money on Your Android Phone</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/05/pixel-3a-xl-differences-hands-on-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/05/3axl-front-75x50.jpg" alt="Google Pixel 3a to 3a XL: Differences, Hands-on Review"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/05/pixel-3a-xl-differences-hands-on-review/" title="Permalink to Google Pixel 3a to 3a XL: Differences, Hands-on Review" rel="bookmark">Google Pixel 3a to 3a XL: Differences, Hands-on Review</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/05/which-color-pixel-3a-xl-should-you-buy/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/05/Pixel-3a-Which-Color-to-Buy-Featured-75x50.png" alt="Which Color Pixel 3a or Pixel 3a XL Should You Buy — Clearly White, Just Black or Purple-ish?"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/05/which-color-pixel-3a-xl-should-you-buy/" title="Permalink to Which Color Pixel 3a or Pixel 3a XL Should You Buy — Clearly White, Just Black or Purple-ish?" rel="bookmark">Which Color Pixel 3a or Pixel 3a XL Should You Buy — Clearly White, Just Black or Purple-ish?</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border: 0;
margin: 0;
padding: 10px 5px 10px 5px;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}

#sidebar  .rpwe-block li:first-child {
padding-top: 0;
}


#sidebar .rpwe-block li:nth-child(even){
background: #f2f2f2;
}

#sidebar .rpwe-thumb {
border: 0 !important;
box-shadow: none !important;
margin: 0 20px 0 0;
padding: 4px 0 0 !important;
}</style><li id="rpwe_widget-2" class="widget-container rpwe_widget recent-posts-extended"><h3 class="widget-title tk-museo-sans">Latest Posts</h3><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/02/tcl-smartphone-slide-out-display/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/02/tcl-slide-out-phone-75x50.jpg" alt="Images of TCL&#8217;s Upcoming Phone with Slide-Out Screen Leaked"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/02/tcl-smartphone-slide-out-display/" title="Permalink to Images of TCL&#8217;s Upcoming Phone with Slide-Out Screen Leaked" rel="bookmark">Images of TCL&#8217;s Upcoming Phone with Slide-Out Screen Leaked</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/02/call-screen-record-audio-disappears-pixel-phones/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/10/pixel-4-orange-75x50.jpg" alt="Call Screen&#8217;s Record Audio Option Has Vanished on Some Pixel Phones"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/02/call-screen-record-audio-disappears-pixel-phones/" title="Permalink to Call Screen&#8217;s Record Audio Option Has Vanished on Some Pixel Phones" rel="bookmark">Call Screen&#8217;s Record Audio Option Has Vanished on Some Pixel Phones</a></h3></li><li class="rpwe-li rpwe-clearfix"><a href="https://www.androidbeat.com/2020/02/samsung-galaxy-z-flip-release-date-price-specs/"><img  class="thumbnail post-thumbnail rpwe-alignleft rpwe-thumb get-the-image" width="75" height="50" alt="Samsung Galaxy Z Flip Release Date, Price, and Specs" itemprop="image" src="https://cdn.androidbeat.com/wp-content/uploads/2020/02/Samsung-Galaxy-Z-Flip-01.jpg" /></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/02/samsung-galaxy-z-flip-release-date-price-specs/" title="Permalink to Samsung Galaxy Z Flip Release Date, Price, and Specs" rel="bookmark">Samsung Galaxy Z Flip Release Date, Price, and Specs</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/02/xiaomi-mi-10-mi-10-pro-with-108mp-camera-snapdragon-865-launched-in-china/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/02/xiaomi-mi-10-pro-75x50.jpeg" alt="Xiaomi Mi 10, Mi 10 Pro with 108MP Camera, Snapdragon 865 Launched in China"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/02/xiaomi-mi-10-mi-10-pro-with-108mp-camera-snapdragon-865-launched-in-china/" title="Permalink to Xiaomi Mi 10, Mi 10 Pro with 108MP Camera, Snapdragon 865 Launched in China" rel="bookmark">Xiaomi Mi 10, Mi 10 Pro with 108MP Camera, Snapdragon 865 Launched in China</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2020/02/gboard-emoji-mashup-tool-emoji-kitchen/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2020/02/emoji-kitchen-75x50.png" alt="Google&#8217;s Latest Gboard Experiment is an emoji mashup feature called &#8216;Emoji Kitchen&#8217;"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2020/02/gboard-emoji-mashup-tool-emoji-kitchen/" title="Permalink to Google&#8217;s Latest Gboard Experiment is an emoji mashup feature called &#8216;Emoji Kitchen&#8217;" rel="bookmark">Google&#8217;s Latest Gboard Experiment is an emoji mashup feature called &#8216;Emoji Kitchen&#8217;</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li><li id="execphp-6" class="widget-container widget_execphp">			<div class="execphpwidget">	<!-- Sortable Desktop 300x600 ATF  size:300x600 -->
	<div class="ad-tag" data-ad-name="Sortable Desktop Skyscraper" data-ad-size="auto" ></div>
	<script src="//tags-cdn.deployads.com/a/androidbeat.com.js" async ></script>
	<script>(deployads = window.deployads || []).push({});</script>
	</div>
		</li><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border: 0;
margin: 0;
padding: 10px 5px 10px 5px;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}

#sidebar  .rpwe-block li:first-child {
padding-top: 0;
}


#sidebar .rpwe-block li:nth-child(even){
background: #f2f2f2;
}

#sidebar .rpwe-thumb {
border: 0 !important;
box-shadow: none !important;
margin: 0 20px 0 0;
padding: 4px 0 0 !important;
}</style><li id="rpwe_widget-3" class="widget-container rpwe_widget recent-posts-extended"><h3 class="widget-title tk-museo-sans">Reviews</h3><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/12/google-pixel-4-xl-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/11/IMG_0418-75x50.jpg" alt="Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/12/google-pixel-4-xl-review/" title="Permalink to Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship" rel="bookmark">Google Pixel 4 XL Review &#8211; six weeks on, still early days for this flagship</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/08/redmi-k20-pro-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/08/redmi-k20-rear-75x50.jpg" alt="Redmi K20 Pro Review: Value Flagship"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/08/redmi-k20-pro-review/" title="Permalink to Redmi K20 Pro Review: Value Flagship" rel="bookmark">Redmi K20 Pro Review: Value Flagship</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/05/pixel-3a-xl-differences-hands-on-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/05/3axl-front-75x50.jpg" alt="Google Pixel 3a to 3a XL: Differences, Hands-on Review"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/05/pixel-3a-xl-differences-hands-on-review/" title="Permalink to Google Pixel 3a to 3a XL: Differences, Hands-on Review" rel="bookmark">Google Pixel 3a to 3a XL: Differences, Hands-on Review</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/05/google-pixel-3a-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/05/googlelogo-75x50.jpg" alt="Google Pixel 3a Review: Peace of Mind and a Superb Camera for the Mainstream"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/05/google-pixel-3a-review/" title="Permalink to Google Pixel 3a Review: Peace of Mind and a Superb Camera for the Mainstream" rel="bookmark">Google Pixel 3a Review: Peace of Mind and a Superb Camera for the Mainstream</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/05/huawei-p30-pro-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/04/huawei-p30-pro-camera-1-75x50.jpg" alt="Huawei P30 Pro Review: Impressive, Inconsistent Flagship!"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/05/huawei-p30-pro-review/" title="Permalink to Huawei P30 Pro Review: Impressive, Inconsistent Flagship!" rel="bookmark">Huawei P30 Pro Review: Impressive, Inconsistent Flagship!</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.androidbeat.com/2019/03/redmi-note-7-pro-review/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://cdn.androidbeat.com/wp-content/uploads/2019/03/redmi-note-7-pro-front-75x50.jpg" alt="Redmi Note 7 Pro Review: Challenging Flagships!"></a><h3 class="rpwe-title"><a href="https://www.androidbeat.com/2019/03/redmi-note-7-pro-review/" title="Permalink to Redmi Note 7 Pro Review: Challenging Flagships!" rel="bookmark">Redmi Note 7 Pro Review: Challenging Flagships!</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li><li id="text-9" class="widget-container widget_text"><h3 class="widget-title tk-museo-sans">Follow Android Beat</h3>			<div class="textwidget"><div class="social-sidebar">
 <ul>
	        <li><a href="//www.facebook.com/pages/Android-Beat/151205568375709" class="entypo-facebook" target="_blank" rel="noopener noreferrer"><i class="fa fa-facebook" aria-hidden="true"></i></a></li>
	        <li><a href="//twitter.com/Android_Beat" class="entypo-twitter" target="_blank" rel="noopener noreferrer"><i class="fa fa-twitter" aria-hidden="true"></i></a></li>
<li><a href="//www.androidbeat.com/feed" class="entypo-rss" target="_blank" rel="noopener noreferrer"><i class="fa fa-rss" aria-hidden="true"></i></a></li>
	    </ul>
</div></div>
		</li>		</ul>
</aside><!-- /#sidebar -->



		
	</div><!-- Row End -->
</div><!-- Container End -->
<div class="row">
	<div class="large-12 columns" id="breadcrumbs">
		<a href="https://www.androidbeat.com">Home</a>
	</div>
	<div class="large-12 columns" id="the-footer">
		<div class="row">
			

			<div id="footer-widget-area" role="complementary">

				<div id="first" class="widget-area large-3 columns">
					<ul class="xoxo">
						<li id="text-3" class="widget-container widget_text"><h3 class="widget-title">Disclaimer</h3>			<div class="textwidget"><div>Android is a trademark of Google Inc. <a class="vglink" href="https://www.androidbeat.com">AndroidBeat.com</a> is not affiliated with Google or any of the device manufacturers listed on this site. All images, logos and trademarks used on this site are property of their respective owners. We are an Android Enthusiast site.</div>
</div>
		</li>					</ul>
				</div><!-- #first .widget-area -->

				<div id="second" class="widget-area large-3 columns">
					<ul class="xoxo">
						<li id="pages-2" class="widget-container widget_pages"><h3 class="widget-title">Pages</h3>		<ul>
			<li class="page_item page-item-65"><a href="https://www.androidbeat.com/about/">About Us</a></li>
<li class="page_item page-item-27"><a href="https://www.androidbeat.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-26"><a href="https://www.androidbeat.com/privacy-policy/">Privacy Policy</a></li>
		</ul>
			</li>					</ul>
				</div><!-- #second .widget-area -->



			</div><!-- #footer-widget-area -->
		</div>
		<div class="row">
			<div class="large-12 columns">
				<p class="design-by">
					Designed by <a href="//www.blogconsulting.com/" rel="nofollow">Blog Consulting</a>
				</p>
			</div>
		</div>
		<div class="fordesign"></div>
	</div>
</div>
</div>

<script type='text/javascript' src='https://cdn.androidbeat.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidbeat"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"31330 https:\/\/www.androidbeat.com\/?p=31330","disqusShortname":"androidbeat","disqusTitle":"Reference to Google Pixel 5 Found in AOSP Code","disqusUrl":"https:\/\/www.androidbeat.com\/2020\/02\/pixel-5-reference-aosp-code\/","postId":"31330"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/lazy-load/js/lazy-load.js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/foundation.min.js'></script>
<script type='text/javascript' src='https://cdn.androidbeat.com/wp-includes/js/wp-embed.min.js'></script>



<!-- <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-53f192b25dff6022" async="async"></script> -->

<script type="text/javascript" src="https://cdn.androidbeat.com/wp-content/themes/androidbeat-new/js/jquery.fitvids.js"></script>
<script type="text/javascript">
var clicky_site_ids = clicky_site_ids || [];
clicky_site_ids.push(100673631);
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//static.getclicky.com/js';
  ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
})();

$(document).ready(function(){
	  $(".container").fitVids();
});	
</script>

<script>
	(function($) {
		$(document).foundation();
	})(jQuery);
</script>


			<script type="text/javascript">
		window._ttf = window._ttf || [];
		_ttf.push({
			   pid          : 62955
			   ,lang        : "en"
			   ,slot        : '.post .entry-content > p'
			   ,format      : "inread"
			   ,minSlot     : 3
			   ,css         : "margin: 10px auto 10px; max-width: 550px;"
		});

		(function (d) {
				var js, s = d.getElementsByTagName('script')[0];
				js = d.createElement('script');
				js.async = true;
				js.src = '//cdn.teads.tv/media/format.js';
				s.parentNode.insertBefore(js, s);
		})(window.document);
		</script>
	
<script type="text/javascript">
    var vglnk = {key: 'c3a020c1da88216e0e531635c6550b00'};
    (function(d, t) {
        var s = d.createElement(t);
            s.type = 'text/javascript';
            s.async = true;
            s.src = '//cdn.viglink.com/api/vglnk.js';
        var r = d.getElementsByTagName(t)[0];
            r.parentNode.insertBefore(s, r);
    }(document, 'script'));
</script>
<script type="text/javascript" src="https://cdn.jsdelivr.net/jquery.jssocials/1.4.0/jssocials.min.js"></script>
<script type="text/javascript">
	jQuery("#share").jsSocials({
		shareIn: "popup",
		showLabel: false,
		showCount: false,
		shares: ["facebook","twitter",{ share: "email", logo: "fa fa-envelope" }]
	});
</script>
</body>
</html>